您的位置:首页 > 大数据 > 人工智能

POJ Organize Your Train part II 3007

2016-10-12 20:27 393 查看
Organize Your Train part II

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8277 Accepted: 2369
Description

RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.



Figure 1: Layout of the exchange lines
A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either.
Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected
in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

[3:1]
abc+d  cba+d  d+abc  d+cba
[2:2]
ab+cd  ab+dc  ba+cd  ba+dc  cd+ab  cd+ba  dc+ab  dc+ba
[1:3]
a+bcd  a+dcb  bcd+a  dcb+a

Excluding duplicates, 12 distinct configurations are possible.

Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

Input

The entire input looks like the following.

the number of datasets = m

1st dataset

2nd dataset

...
m-th dataset

Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

Output

For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

Sample Input
4
aa
abba
abcd
abcde

Sample Output
1
6
12
18

Source
Japan 2006 Domestic

题意:

给定一个字符串,从任意位置把它切为两半,得到两条子串

定义 子串1为s1,子串2为s2,子串1的反串为s3,子串2的反串为s4

现在从s1 s2 s3 s4中任意取出两个串组合,问有多少种不同的组合方法

分析:主要是哈希,一开始用的set,超时,最后用了一个不是太好的哈希

烂代码

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <set>
using namespace std;
#define inf 40007
char str[500][80];
struct node
{
int g;
struct node *next;
};
struct node *h[50000],*p,*q,*r;
int top=0;
int ct=0;
void lianjie(char s1[],char s2[])
{
char ss1[100];
strcpy(ss1,s1);
int i,j;
char ss[100];
int ans=0;
strcpy(ss,strcat(ss1,s2));
int l=strlen(ss);
for(i=0;i<l;i++)
{
ans+=((ss[i]-'a'+1)*(i+1));
}
ans%=inf;
if(h[ans]==NULL)
{
strcpy(str[top],ss);
p=new node;
p->g=top;
p->next=NULL;
top++;
h[ans]=p;
ct++;
}
else
{
int flag=0;
q=h[ans];
while(q)
{
if(strcmp(str[q->g],ss)==0)
{
flag=1;
break;
}
q=q->next;
}
if(!flag)
{
q=h[ans];
while(q->next)
{
q=q->next;
}
strcpy(str[top],ss);
p=new node;
p->g=top;
p->next=NULL;
top++;
q->next=p;
ct++;
}
}

}
void f(int l,int r,char s[])
{
int i,j;
char s1[100],s2[100],s3[100],s4[100];
for(i=0;i<l;i++)
{
s1[i]=s[i];
s2[l-i-1]=s[i];
}
s1[l]=s2[l]='\0';
for(i=l;i<r;i++)
{
s3[i-l]=s[i];
s4[r-i-1]=s[i];
}
s3[r-l]=s4[r-l]='\0';
lianjie(s1,s3);
lianjie(s3,s1);
lianjie(s2,s3);
lianjie(s3,s2);
lianjie(s1,s4);
lianjie(s4,s1);
lianjie(s2,s4);
lianjie(s4,s2);
}
void init()
{
ct=0;
for(int i=0;i<=49999;i++)
{
h[i]=NULL;
}
top=0;
}
int main()
{
int n,m,i,j;
char s[100];
scanf("%d",&n);
while(n--)
{
init();
scanf("%s",s);
int l=strlen(s);
if(l==1)
{
printf("1\n");
}
else
{
for(i=1;i<l;i++)
{
f(i,l,s);
}
printf("%d\n",top);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj