您的位置:首页 > 其它

hdu 1845 Jimmy’s Assignment (二分匹配)

2016-10-11 21:39 501 查看

Problem Description

Jimmy is studying Advanced Graph Algorithms at his university. His most recent assignment is to find a maximum matching in a special kind of graph. This graph is undirected, has N vertices and each vertex has degree 3. Furthermore, the graph
is 2-edge-connected (that is, at least 2 edges need to be removed in order to make the graph disconnected). A matching is a subset of the graph’s edges, such that no two edges in the subset have a common vertex. A maximum matching is a matching having the
maximum cardinality.

  Given a series of instances of the special graph mentioned above, find the cardinality of a maximum matching for each instance.

Input

The first line of input contains an integer number T, representing the number of graph descriptions to follow. Each description contains on the first line an even integer number N (4<=N<=5000), representing the number of vertices. Each of
the next 3*N/2 lines contains two integers A and B, separated by one blank, denoting that there is an edge between vertex A and vertex B. The vertices are numbered from 1 to N. No edge may appear twice in the input.

Output

For each of the T graphs, in the order given in the input, print one line containing the cardinality of a maximum matching.

Sample Input

2
4
1 2
1 3
1 4
2 3
2 4
3 4
4
1 2
1 3
1 4
2 3
2 4
3 4


Sample Output

2
2


题意:求最大匹配的边数,每个顶点最多只能用一次。

思路:用邻接表存数据,然后二分匹配,由于是双向建图,所以得出的结果要除以2;

注意:很卡时间,while 比 for 循环快,所以尽可能的用while


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=5005;
struct node{
int now,next;
}str[N*3];
int n,len;
int head
,vis
,link
;
void add(int a,int b)
{
str[len].now=b;
str[len].next=head[a];
head[a]=len++;
}
int find(int u)
{
for(int i=head[u];i!=-1;i=str[i].next)
{
int v=str[i].now;
if(!vis[v])
{
vis[v]=1;
if(!link[v]||find(link[v]))
{
link[v]=u;
return 1;
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
memset(head,-1,sizeof(head));
memset(link,0,sizeof(link));
int k=(3*n)/2;
len=0;
while(k--) //这里必须用while,不然会超时;
{
int a,b;
scanf("%d%d",&a,&b);
add(a,b);
add(b,a);
}
int s=0;
for(int i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
s+=find(i);
}
printf("%d\n",s/2);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: