您的位置:首页 > 其它

HDU 5768 Lucky7 中国剩余定理+状压+容斥+快速乘法

2016-10-11 21:00 483 查看

Lucky7

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1550    Accepted Submission(s): 577
[/b]

[align=left]Problem Description[/align]
When ?? was born, seven crows flew in and stopped beside him. In its childhood, ?? had been unfortunately fall into the sea. While it was dying, seven dolphins arched its body and sent it back to the shore. It is said that ?? used
to surrounded by 7 candles when he faced a extremely difficult problem, and always solve it in seven minutes.

?? once wrote an autobiography, which mentioned something about himself. In his book, it said seven is his favorite number and he thinks that a number can be divisible by seven can bring him good luck. On the other hand, ?? abhors some other prime numbers and
thinks a number x divided by pi which is one of these prime numbers with a given remainder ai will bring him bad luck. In this case, many of his lucky numbers are sullied because they can be divisible by 7 and also has a remainder of ai when it is divided
by the prime number pi.

Now give you a pair of x and y, and N pairs of ai and pi, please find out how many numbers between x and y can bring ?? good luck.
 

[align=left]Input[/align]
On the first line there is an integer T(T≤20) representing the number of test cases.

Each test case starts with three integers three intergers n, x, y(0<=n<=15,0<x<y<1018)
on a line where n is the number of pirmes.

Following on n lines each contains two integers pi, ai where pi is the pirme and ?? abhors the numbers have a remainder of ai when they are divided by pi.

It is guranteed that all the pi are distinct and pi!=7.

It is also guaranteed that p1*p2*…*pn<=1018
and 0<ai<pi<=105for
every i∈(1…n).

 

[align=left]Output[/align]
For each test case, first output "Case #x: ",x=1,2,3...., then output the correct answer on a line.
 

[align=left]Sample Input[/align]

2
2 1 100
3 2
5 3
0 1 100

 

[align=left]Sample Output[/align]

Case #1: 7
Case #2: 14

HintFor Case 1: 7,21,42,49,70,84,91 are the seven numbers.
For Case2: 7,14,21,28,35,42,49,56,63,70,77,84,91,98 are the fourteen numbers.

 

[align=left]Author[/align]
FZU
 

[align=left]Source[/align]
2016 Multi-University Training Contest 4

 

[align=left]Recommend[/align]
wange2014   |   We have carefully selected several similar problems for you:  5932 5931 5930 5928 5925 
 

求l,r范围是7的倍数 并且满足一些同余方程的数有几个。
因为n只有15个,很快想到了用容斥来做。
然后对所有的可能,跑中国剩余定理就行了
#include <bits/stdc++.h>
using namespace std;
#define N 20
#define LL long long
LL a
, m
;
int s
, n;
LL extend_Euclid(LL a, LL b, LL &x, LL &y)
{
if(b==0)
{
x = 1;
y = 0;
return a;
}
LL r = extend_Euclid(b, a%b, y, x);
y -= a/b*x;
return r;
}
LL gao(LL x, LL r, LL p)
{
return (x-r)/p;
}
LL mult(LL a, LL k, LL m)
{
LL res = 0;
while(k)
{
if(k & 1LL)
res = (res + a) % m;
k >>= 1;
a = (a << 1) % m;
}
return res;
}
LL China(LL l, LL r)
{
LL M = 1, ans = 0;
for (int i = 0; i <= n; ++i) if(s[i])
{
M *= m[i];
}
for(int i = 0; i <= n; i++) if(s[i])
{
LL Nn = M/m[i];
LL x, y;
extend_Euclid(Nn, m[i], x, y);
x = (x%m[i] + m[i]) % m[i];
ans = ((ans+mult(a[i]*Nn%M, x, M))%M + M) % M ;
}
LL ret = gao(r+M, ans, M) - gao(l-1+M, ans, M);
return ret;
}
int main()
{
int T, o = 0;
scanf("%d", &T);
while(T--)
{
LL l, r;
scanf("%d%lld%lld", &n, &l, &r);
memset(s, 0, sizeof(s));
m
= 7;
a
= 0;
s
= 1;
for(int i = 0; i < n; i++)
scanf("%lld%lld", &m[i], &a[i]);
LL ans = 0;
int all = 1 << n;
for(int i = 0; i < all; i++)
{
int t = i, k = 0;
for(int j = 0; j < n; j++)
{
s[j] = t & 1;
t >>= 1;
k += s[j];
}
k = k & 1 ? -1 : 1;
ans += 1LL * k * China(l, r);
}
printf("Case #%d: %lld\n", ++o, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM算法