您的位置:首页 > 其它

poj 3414 Pots (BFS + 记录路径)

2016-10-11 18:04 525 查看
题目链接:http://poj.org/problem?id=3414

Pots

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14702 Accepted: 6182 Special Judge
Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
DROP(i)      empty the pot i to the drain;
POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its
contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbe
4000
rs AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the
desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4

Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

Source

Northeastern Europe 2002, Western Subregion
[Submit]   [Go Back]   [Status]  
[Discuss]

题目大意:给你两个水壶的容量a,   b,然后给你目标容量c ,共三种操作方式,把 i 倒满, 把 i 全部倒掉, 把 i 倒入 j 内,求变化的最少

                  次数得到c,并输出路径,不可能输出impossible

解析:BFS 模拟所以情况(共6种),搜到 c 时,退出循环,最后递归输出

           借鉴大牛博客:http://www.cnblogs.com/Lyush/archive/2012/11/16/2774068.html

代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 209
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
int a, b, c;
int mp

, g

;

struct node
{
int x, y, s;
};

int bfs()
{
queue<node> q;
memset(mp, 0, sizeof(mp));
node now, nn;
now.s = now.x = now.y = 0;
q.push(now);
while(!q.empty())
{
now = q.front(); q.pop();
nn.s = now.s + 1;
nn.x = a; nn.y = now.y;
if(!mp[nn.x][nn.y]) {q.push(nn); mp[nn.x][nn.y] = 1; g[nn.x][nn.y] = now.x * 1000 + now.y; if(nn.x == c || nn.y == c) break;}
nn.x = now.x; nn.y = b;
if(!mp[nn.x][nn.y]) {q.push(nn); mp[nn.x][nn.y] = 2; g[nn.x][nn.y] = now.x * 1000 + now.y; if(nn.x == c || nn.y == c) break;}
nn.x = 0; nn.y = now.y;
if(!mp[nn.x][nn.y]) {q.push(nn); mp[nn.x][nn.y] = 3; g[nn.x][nn.y] = now.x * 1000 + now.y; if(nn.x == c || nn.y == c) break;}
nn.x = now.x; nn.y = 0;
if(!mp[nn.x][nn.y]) {q.push(nn); mp[nn.x][nn.y] = 4; g[nn.x][nn.y] = now.x * 1000 + now.y; if(nn.x == c || nn.y == c) break;}
nn.x = now.x - min(now.x, b - now.y); nn.y = now.y + now.x - nn.x;
if(!mp[nn.x][nn.y]) {q.push(nn); mp[nn.x][nn.y] = 5; g[nn.x][nn.y] = now.x * 1000 + now.y; if(nn.x == c || nn.y == c) break;}
nn.y = now.y - min(now.y, a - now.x); nn.x = now.x + now.y - nn.y;
if(!mp[nn.x][nn.y]) {q.push(nn); mp[nn.x][nn.y] = 6; g[nn.x][nn.y] = now.x * 1000 + now.y; if(nn.x == c || nn.y == c) break;}
}
if(nn.x == c || nn.y == c) { a = nn.x; b = nn.y; c = nn.s; return 1;}
return 0;
}

void Display(int u, int v)
{
if(u + v == 0) return ;
Display(g[u][v] / 1000, g[u][v] % 1000);
switch(mp[u][v])
{
case 1 : printf("FILL(1)\n"); break;
case 2 : printf("FILL(2)\n"); break;
case 3 : printf("DROP(1)\n"); break;
case 4 : printf("DROP(2)\n"); break;
case 5 : printf("POUR(1,2)\n"); break;
case 6 : printf("POUR(2,1)\n"); break;
}
}

int main()
{
scanf("%d%d%d", &a, &b, &c);
if(bfs()) { printf("%d\n", c); Display(a, b); }
else printf("impossible\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: