您的位置:首页 > 产品设计 > UI/UE

poj 1019 Number Sequence

2016-10-10 21:56 309 查看
Number Sequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38489 Accepted: 11168
Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 

For example, the first 80 digits of the sequence are as follows: 

11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output

There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3

Sample Output
2
2


题意:
/*
转自: http://user.qzone.qq.com/289065406/blog/1301527312

有一串数字串,其规律为

1 12 123 1234 12345 123456 1234567 12345678 123456789 12345678910 1234567891011 123456789101112······k

输入位置n,计算这一串数字第n位是什么数字,注意是数字,不是数!例如12345678910的第10位是1,而不是10,第11位是0,也不是10。总之多位的数在序列中要被拆分为几位数字,一个数字对应一位。

解题思路:

首先建议数学底子不好的同学,暂时放一放这题,太过技巧性了,连理解都很困难 

模拟分组,把1看做第1组,12看做第2组,123看做第3组……那么第i组就是存放数字序列为 [1,i]的正整数,但第i组的长度不一定是i

已知输入查找第n个位的n的范围为(1 ≤ n ≤ 2147483647),那么至少要有31268个组才能使得数字序列达到有第2147483647位

注意:2147483647刚好是int的正整数最大极限值( ),所以对于n用int定义就足矣。但是s[31268]存在超过2147483647的位数,因此要用unsigned 或long 之类的去定义s[]
*/

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
using namespace std;

long long a[40000];
long long b[40000];

void dabiao()
{
int i;
a[1] = b[1] = 1;
for ( i = 2;i < 40000; i++ )
{
a[i] = a[i-1]+(int)log10((double)i)+1;     //第i组位数
b[i] = b[i-1]+a[i];                                     //前i组位数
}
}

int jisuan(int n)
{
int i = 1, j;
while ( b[i] < n )
i++;
int differ = n-b[i-1];
int k = 0;
for ( j = 1;j <= i; j++ )
{
k = k+(int)log10((double)j)+1;               //到该数的位数
if ( k >= differ )
break;
}
int differ1 = k-differ+1;
int sum = pow(10, differ1 );
return j%sum/(sum/10);
}

int main()
{
int T, n;
dabiao();
scanf( "%d", &T );
while ( T-- )
{
scanf ( "%d", &n );
int sum = jisuan(n);
printf ( "%d\n", sum );
}
}


代码菜鸟,如有错误,请多包涵!!
如有帮助记得支持我一下,谢谢!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: