您的位置:首页 > 其它

hdu 1250 Hat's Fibonacci

2016-10-10 20:45 246 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250

题目描述:

Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. 

F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) 

Your task is to take a number as input, and print that Fibonacci number. 

Input

Each line will contain an integers. Process to end of file. 

Output

For each case, output the result in a line.

Sample Input

100


Sample Output

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


题目分析:

二维数组,但是如果每个位置存储10(即0~9中的某一个)会超内存,所以在这里我每个位置存储8位数(即0~100000000)

AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#define MOD 100000000
using namespace std;
int v[8000][305];
void Init()
{
v[1][1]=1;
v[2][1]=1;
v[3][1]=1;
v[4][1]=1;
for(int i=5;i<8000;i++)
{
for(int j=1;j<300;j++)
v[i][j]=v[i-1][j]+v[i-2][j]+v[i-3][j]+v[i-4][j];
for(int j=1;j<300;j++)
{
if(v[i][j]/MOD)
{
v[i][j+1]+=(v[i][j]/MOD);
v[i][j]%=MOD;
}
}
}
}
int main()
{
Init();
int n;
while(scanf("%d",&n)!=EOF)
{
int k;
for(k=300;k>=1;k--)
{
if(v
[k])
break;
}
printf("%d",v
[k]);
for(int j=k-1;j>=1;j--)
{
printf("%08d",v
[j]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: