您的位置:首页 > 其它

poj 2155 Matrix 二维树状数组

2016-10-10 16:44 375 查看
Matrix

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 25231 Accepted: 9354
Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 

2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output
1
0
0
1

Source

POJ Monthly,Lou Tiancheng

题意:

给出一个01正方形矩阵(2 <=边长  N <= 1000),Q次操作(1
<= Q<= 50000)每次操作可指定一个矩形区域内的数字翻转或者

查询某个点的值。

解法:二维树状数组

论文:浅谈信息学竞赛中的“0”和“1”

要点:对于一维的问题 [x,y]区间反转,那么在x点处+1,在y+1点处+1,更新树状数组,查询某个点x的值时,只需要计算sum[1,x],并

判断奇偶性即可,如果为奇数则为1。

对于二维的问题,不难发现给出左上角(x1,y1) 和右下角(x2,y2),需要将(x1,y1),(x1,y2+1),(x2+1,y1),(x2+1,y2+1)的变更次数+1即可。

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s) memset(a,x,(s)*sizeof a[0])
#define mem(a,x) memset(a,x,sizeof a)
#define ysk(x) (1<<(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxN= 1000 ;
int N;

struct BitTree
{
int n,C[maxN+3][maxN+3];

void init()
{
n=N+1;
for1(i,n) mem(C[i],0);

}
void add(int x,int y)
{
for(int i=x;i<=n;i+= i&(-i) )
{
for(int j=y;j<=n;j+=j&(-j))
{
C[i][j]++;
}
}
}
int query(int x,int y)
{
int ans=0;
for(int i=x;i;i-=i&(-i) )
{
for(int j=y;j;j-=j&(-j) )
{
ans+=C[i][j];
}
}
return ans;
}
}bt;
void read()
{
int x[2],y[2];char op;
cin>>op;
if(op=='C')
{
cin>>x[0]>>y[0]>>x[1]>>y[1];
bt.add(x[0],y[0]);
bt.add(x[0],y[1]+1);
bt.add(x[1]+1,y[0]);
bt.add(x[1]+1,y[1]+1);
}
else
{
cin>>x[0]>>y[0];
int ans=bt.query(x[0],y[0]);
// cout<<ans<<endl;
puts(ans&1?"1":"0");
}

}
int main()
{
std::ios::sync_with_stdio(false);
int T,kase=0,Q;cin>>T;
while(T--)
{
if(kase++) putchar('\n');
cin>>N>>Q;
bt.init();
while(Q--) read();
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: