您的位置:首页 > 其它

【poj 1942】Paths on a Grid 组合数学

2016-10-09 23:44 435 查看


Paths on a Grid 

Time Limit: 1000MS Memory Limit: 30000K 

Total Submissions: 23972 Accepted: 5925

Description 

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he’s explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art
instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let’s call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:

Really a masterpiece, isn’t it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input 

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output 

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up?
You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4 

1 1 

0 0

Sample Output

126 

2

Source 

Ulm Local 2002

题目大意:问从左下角走到右上角的方法数,只能向上或向右。

对于一条路径来说,一共有n+m部分,,n个向上的,m个向右的,所以只要找出在这n+m个部分中,n或m的分布方式,就可以得到总数。

也就是结果就是C(n+m,m) ;
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
int main()
{
LL n,m,nn,minn;
while(scanf("%lld%lld",&n,&m)&&m||n)
{
LL ans=1,sum=1,t=1;
nn=n+m;
if(n>m)
minn=m;
else  minn=n;
for(LL i=1;i<=minn;i++,nn--)
{
sum*=nn;
ans*=i;
if(sum%ans==0)
{
sum=sum/ans;
ans=1;
}
}
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: