您的位置:首页 > 其它

POJ 1328 - Radar Installation(贪心)

2016-10-09 21:02 211 查看
Radar Installation

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 78169 Accepted: 17491

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

Source

题意:

给出N个点和雷达的搜索半径,求在x轴上最少分布多少个雷达.

解题思路:

对于每个点,找出能搜索到的雷达在x轴上的分布.那么就是一个区间选点问题.



数轴上有n个闭区间[ai,bi]。取尽量少的点,使得每个区间内都至少有一个点(不同区间内含的点可以是同一个)。

贪心策略:

按照b1<=b2<=b3…(b相同时按a从大到小)的方式排序排序,从前向后遍历,当遇到没有加入集合的区间时,选取这个区间的右端点b。

证明:

为了方便起见,如果区间i内已经有一个点被取到,我们称区间i被满足。

1、首先考虑区间包含的情况,当小区间被满足时大区间一定被满足。所以我们应当优先选取小区间中的点,从而使大区间不用考虑。

按照上面的方式排序后,如果出现区间包含的情况,小区间一定在大区间前面。所以此情况下我们会优先选择小区间。

则此情况下,贪心策略是正确的。

2、排除情况1后,一定有a1<=a2<=a3……。

AC代码:

#include<stdio.h>
#include<math.h>
#include<limits.h>
#include<algorithm>
using namespace std;
struct node
{
double left;
double right;
}qdu[1000];
bool cmp1(node a,node b)
{
return a.left>b.left;
}
bool cmp2(node a,node b)
{
return a.right<b.right;
}
int main()
{
int n;
double d;
int flag = 1;
while(~scanf("%d%lf",&n,&d),n||d)
{
int bf = 0;
if(d<0) bf = 1;
for(int i = 0;i < n;i++)
{
double x;
double y;
scanf("%lf%lf",&x,&y);
if(y > d)   bf = 1;
qdu[i].left =  x-sqrt(d*d-y*y);
qdu[i].right = x+sqrt(d*d-y*y);
}
if(bf)
{
printf("Case %d: -1\n",flag++);
continue;
}
sort(qdu,qdu+n,cmp1);
sort(qdu,qdu+n,cmp2);
int cnt = 0;
double radar = INT_MIN;
for(int i = 0;i < n;i++)
{
if(radar < qdu[i].left)
{
cnt++;
radar = qdu[i].right;
}
}
printf("Case %d: %d\n",flag++,cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: