您的位置:首页 > 其它

POJ 3687 Labeling Balls

2016-10-09 20:37 363 查看
Labeling Balls

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13926 Accepted: 4025
Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating
the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest
weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input
5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778

因为要求小的尽量往前排,所以普通的拓扑排序就不可以了,要进行反向建图。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int map[210][210];
int indegree[1100];
int qu[1100];
void tuopu(int n)
{
int i,k,j;
for(i=n;i>=1;i--)
{
for(j=n;j>=1;j--)
{
if(indegree[j]==0)
{
indegree[j]=-1;
qu[j]=i;
for(k=1;k<=n;k++)
if(map[j][k])
indegree[k]--;
break;
}
}
if(j<1)
break;
}
if(i>=1)
printf("-1\n");
else
{
for(i=1;i<n;i++)
printf("%d ",qu[i]);
printf("%d\n",qu[i]);
}
}
int main()
{
int n,m,t,a,b,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
memset(map,0,sizeof(map));
memset(indegree,0,sizeof(indegree));
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
if(map[b][a]==0)
{
map[b][a]=1;
indegree[a]++;
}

}
tuopu(n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: