您的位置:首页 > 其它

顺序表应用6:有序顺序表查询

2016-10-08 20:00 106 查看

顺序表应用6:有序顺序表查询

Time Limit: 7MS
Memory Limit: 700KB
[align=center][/align]

Problem Description

顺序表内按照由小到大的次序存放着n个互不相同的整数(1<=n<=20000),任意输入一个整数,判断该整数在顺序表中是否存在。如果在顺序表中存在该整数,输出其在表中的序号;否则输出“No Found!"。

Input

 第一行输入整数n,表示顺序表的元素个数;

第二行依次输入n个各不相同的有序整数,代表表里的元素;

第三行输入整数t,代表要查询的次数;

第四行依次输入t个整数,代表每次要查询的数值。

Output

 输出t行,代表t次查询的结果,如果找到在本行输出该元素在表中的位置,否则本行输出No Found!

Example Input

10
1 22 33 55 63 70 74 79 80 87
4
55 10 2 87


Example Output

4
No Found!
No Found!
10
#include<stdio.h>
typedef struct node
{
int len;
int *elem;
}List;
void creat(List &l,int n)
{
int i;
l.len=n;
l.elem=new int[11000];
for(i=0;i<n;i++)
scanf("%d",&l.elem[i]);
}

void local(List &l,int x)
{
int low=0;
int high=l.len-1;
while(low<=high)
{
int mid = (low+high)/2;
if(l.elem[mid]==x)
{
printf("%d\n",mid+1); return;
}
else if(l.elem[mid]>x) high=mid-1;
else low =mid +1;
}
printf("No Found!\n");
}
int main()
{
int n,m;
List l;
scanf("%d",&n);
creat(l,n);
scanf("%d",&m);
while(m--)
{
int x;
scanf("%d",&x);
local(l,x);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: