您的位置:首页 > 其它

hdu 1969 二分法分蛋糕

2016-10-08 19:27 375 查看
G - Pie
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
1969

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This
should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. 

Input

One line with a positive integer: the number of test cases. Then for each test case: 

---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. 

---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies. 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2


Sample Output

25.1327
3.1416
50.2655

二分法

#include<stdio.h>
#include<math.h>
double PI;
double a[10010];
int n,t,f;
bool text(double x);
int main()
{
double s,left,right,mid;
int i;
int r;
PI=acos(-1.0);//精度更高
scanf("%d",&t);
while(t--)
{    s=0;
scanf("%d %d",&n,&f);
f++;//除了朋友还要加上自己;
for(i=0;i<n;i++)
{  scanf("%d",&r);
a[i]=PI*r*r;
s+=a[i];
}
right=s/f*1.0;
left=0;
while(left+0.000006<right)
{   mid=(left+right)/2;
if(text(mid))
left=mid;
else
right=mid;
}
printf("%.4lf\n",left);

}
return 0;
}
bool text (double x)
{   int i;
int k=0;
for(i=0;i<n;i++)
{   k+=int(a[i]/x);
if(k>=f) return true;}
return false;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 二分