您的位置:首页 > 其它

Count the string 动态规划

2016-10-08 16:59 183 查看

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9293    Accepted Submission(s): 4324


Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007. 

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters. 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007. 

Sample Input

1
4
abab 

Sample Output

6

dt[i]表示该字符串前i个字符中出现任意以第i个字符结尾的前缀的次数,它的递推式是 dt[i]=d[next[i]]+1

即以第i个字符结尾的前缀数等于以第next[i]个字符为结尾的前缀数加上它自己本身
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int nexxt[200005];
char st[200005];
int n, dt[200005];

int main()
{
int t;
scanf("%d", &t);
while (t--)
{
int ans = 0;
cin >> n >> st;
int i = 0,j = -1;
nexxt[0] = -1;
while(i < n)
{
if(j == -1 || st[i] == st[j])
nexxt[++i] = ++j;
else
j = nexxt[j];
}
memset(dt,0,sizeof(dt));
for (int k = 1; k <= n; k++)
{
dt[k] = dt[nexxt[k]] + 1;
ans = (ans + dt[k])%10007;
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划