您的位置:首页 > 其它

HDU 5726 GCD(rmq+二分)

2016-10-07 21:35 423 查看

GCD

[b]Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2930    Accepted Submission(s): 1058
[/b]

[align=left]Problem Description[/align]
Give you a sequence of N(N≤100,000)
integers : a1,...,an(0<ai≤1000,000,000).
There are Q(Q≤100,000)
queries. For each query l,r
you have to calculate gcd(al,,al+1,...,ar)
and count the number of pairs(l′,r′)(1≤l<r≤N)such
that gcd(al′,al′+1,...,ar′)
equal gcd(al,al+1,...,ar).

 

[align=left]Input[/align]
The first line of input contains a number
T,
which stands for the number of test cases you need to solve.

The first line of each case contains a number N,
denoting the number of integers.

The second line contains N
integers, a1,...,an(0<ai≤1000,000,000).

The third line contains a number Q,
denoting the number of queries.

For the next Q
lines, i-th line contains two number , stand for the
li,ri,
stand for the i-th queries.

 

[align=left]Output[/align]
For each case, you need to output “Case #:t” at the beginning.(with quotes,
t
means the number of the test case, begin from 1).

For each query, you need to output the two numbers in a line. The first number stands for
gcd(al,al+1,...,ar)
and the second number stands for the number of pairs(l′,r′)
such that gcd(al′,al′+1,...,ar′)
equal gcd(al,al+1,...,ar).

 

[align=left]Sample Input[/align]

1
5
1 2 4 6 7
4
1 5
2 4
3 4
4 4

 

[align=left]Sample Output[/align]

Case #1:
1 8
2 4
2 4
6 1

 

[align=left]Author[/align]
HIT
 

[align=left]Source[/align]
2016 Multi-University Training Contest 1

 

[align=left]Recommend[/align]
wange2014   |   We have carefully selected several similar problems for you:  5932 5931 5930 5928 5925 
 

第一问询问任意区间的gcd值,第二问询问有多少区间的gcd值等于这个。
预处理所有值可能的gcd值的可能的总数。因为二分的过程是单调减小的。找到那个等于gcd的区间,加上去就好
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <stdlib.h>
using namespace std;
typedef long long LL;
const int N=1e5+100;
int dp
[20];
int mm
;
int n;
map<int,LL>mp;
void initrmq()
{
mm[0]=-1;
for(int i=1; i<=n; i++)
mm[i]=((i&(i-1))==0)?mm[i-1]+1:mm[i-1];
for(int j=1; j<=mm
; j++)
for(int i=1; i+(1<<j)-1<=n; i++)
dp[i][j]=__gcd(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}
int rmq(int x,int y)
{
int k=mm[y-x+1];
return __gcd(dp[x][k],dp[y-(1<<k)+1][k]);
}
int main()
{
int t;
scanf("%d",&t);
int Case=0;
while(t--)
{
scanf("%d",&n);
for(int i=1; i<=n; i++)scanf("%d",&dp[i][0]);
initrmq();
mp.clear();
for(int i=1; i<=n; i++)
{
int l=i;
int r=n;
int v,tmp,mid;
while(1)
{
v=rmq(i,l);
tmp=l;
while(l<=r)
{
mid=(l+r)>>1;
if(rmq(i,mid)<v)
r=mid-1;
else
l=mid+1;
}
mp[v]+=1LL*(r-tmp+1);
r=n;
if(l>r)
break;
}
}
int a,b;
int m;
printf("Case #%d:\n",++Case);
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&a,&b);
int vv=rmq(a,b);
printf("%d %lld\n",vv,mp[vv]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM算法