您的位置:首页 > Web前端

HDU 1829 A Bug's Life 并查集

2016-10-06 21:34 387 查看

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1025 Accepted Submission(s): 376
 
Problem Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 

Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 
Output

            The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the
bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4


 
Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
HintHuge input,scanf is recommended.

 
 
Source

题目大意:

给出 n 个人  m  个信息,   然后  给出  a  b   ,a  b  性别不同。然后问:有没有矛盾。

思路:

相当于建立两个并查集,同性放在一起。

如果  a 为 boy  那么 a+n 为 girl  。然后就这样了。

AC代码:

#include <iostream>
#include<stdio.h>
using namespace std;
const int MAX = 30000;
int n,m,k;
int parent[MAX+10];
int GetParent(int a)
{
if( parent[a]!= a)
parent[a] = GetParent(parent[a]);
return parent[a];
}
void Merge(int a,int b)
{
int p1 = GetParent(a);
int p2 = GetParent(b);
if( p1 == p2 )
return;
parent[p2] = p1;
}
int main()
{
int T;
scanf("%d",&T);
int kk=1;
while(T--)
{
cout<<"Scenario #"<<kk<<":"<<endl;
scanf("%d%d",&n,&m);
for(int i = 0;i <= 2*n; ++i)
{
parent[i] = i;
}
int work=0;
for(int i = 0;i < m; ++i)
{
int h,s;
scanf("%d",&h);
scanf("%d",&s);
if(work)
continue;
if(GetParent(h)==GetParent(s))
work=1;
else
{
Merge(h,s+n);
Merge(s,h+n);
}
}
if(work)
cout<<"Suspicious bugs found!"<<endl<<endl;
else
cout<<"No suspicious bugs found!"<<endl<<endl;
kk++;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 并查集