您的位置:首页 > 大数据 > 人工智能

HDU 1022 Train Problem I (模拟栈)

2016-10-06 19:06 441 查看

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32386    Accepted Submission(s): 12221


[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the
world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway
before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway
in an order O1, your task is to determine whether the trains can get out in an order O2.







 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input
is terminated by the end of file. More details in the Sample Input.
[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting
into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
[align=left]Sample Input[/align]

3 123 321
3 123 312

[align=left]Sample Output[/align]

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

[align=left]Author[/align]
Ignatius.L
[align=left]Recommend[/align]
We have carefully selected several similar problems for you:  1023 1020 1087 1873 1062 
 题解:就是模拟一下栈的过程。

AC代码:
#include<bits/stdc++.h>
using namespace std;
int n;
stack<char> s;
string str1,str2,ans;
int id1,id2,flag;
int main()
{
while(cin>>n)
{
flag=1;
id1 = 0;
id2 = 0;
ans="";
cin>>str1;
cin>>str2;
while(!s.empty())
s.pop();
for(int i = 0;i < n;)
{
if(s.empty())
{
s.push(str1[i++]);
ans+="in\n";
continue;
}
if(s.top()==str2[id2])
{
s.pop();
id2++;
ans+="out\n";
}
else
{
s.push(str1[i++]);
ans+="in\n";
}
}

if(!s.empty())
{
while(1)
{
if(s.empty())
break;
if(s.top()==str2[id2])
{
s.pop();
id2++;
ans+="out\n";
}
else
{
flag=0;
break;
}
}
}
if(flag)
cout<<"Yes.\n"<<ans<<"FINISH"<<endl;
else
cout<<"No.\n"<<"FINISH"<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: