您的位置:首页 > 其它

2016CCPC东北地区大学生程序设计竞赛-Minimum’s Revenge

2016-10-06 15:15 459 查看


Minimum’s Revenge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

There is a graph of n vertices which are indexed from 1 to n. For any pair of different vertices, the weight of the edge between them is the least common multiple of their indexes.

Mr. Frog is wondering about the total weight of the minimum spanning tree. Can you help him?

 

Input

The first line contains only one integer T (T≤100),
which indicates the number of test cases.

For each test case, the first line contains only one integer n (2≤n≤109),
indicating the number of vertices.

 

Output

For each test case, output one line "Case #x:y",where x is the case number (starting from 1) and y is the total weight of the minimum spanning tree.

 

Sample Input

2
2
3

 

Sample Output

Case #1: 2
Case #2: 5
Hint
In the second sample, the graph contains 3 edges which are (1, 2, 2), (1, 3, 3) and (2, 3, 6). Thus the answer is 5.
解题思路:最小公倍数大于或等于两数中的任何一个。所以让2~n跟1相连就是最小生成树权值总和2+3+4+……+n开始差点想用Prim和gcd,too young too naive!
#include<iostream>
#include<cstdio>
using namespace std;
typedef long long LL;

int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int T;
cin>>T;
LL n;
for(int i=1;i<=T;i++)
{
cin>>n;
cout<<"Case #"<<i<<": "<<(n+2)*(n-1)/2<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐