您的位置:首页 > 其它

poj 3087 Shuffle'm Up(模拟)

2016-10-06 14:45 696 查看
题目链接:http://poj.org/problem?id=3087

Shuffle'm Up

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9703 Accepted: 4476
Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips.
Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:



The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost
chip from S1. The interleaving process continues taking the 2ndchip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom
of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips
from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N[/b] ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2).
The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips
in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each
dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or
more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the
desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output
1 2
2 -1

Source

Greater New York 2006
[Submit]   [Go Back]   [Status]  
[Discuss]

题目大意:给出三个字符串,s1, s2的长度为c,s12的长度为2 * c,s2不变,s1倒排插入到
s2 中,得到s,如果s != s12,

                     将 s 的前c个字符给s1,赋值,组成新的s1,剩下的给s2赋值, 重复操作, 直到s == s12,  输出组合了几次,不可能输出-1

解析:用map减少操作,如果重复出现s,就返回,输出-1

代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 209
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
char s12
, s1
, s2
, s
;
map<string, int> mp;
int c;

int solve()
{
mp.clear();
int sept = 0, i, j;
while(1)
{
j = 0;
for(i = 0; i < c; i++)
{
s[j++] = s2[i]; s[j++] = s1[i];
}
s[j] = 0;
if(!mp.count(s)) mp[s] = 0;
mp[s]++;
sept++;
if(mp[s] == 2) return -1;
if(strcmp(s12, s) == 0) return sept;
for(i = 0; i < c; i++)
{
s1[i] = s[i];
s2[i] = s[i + c];
}
s1[c] = s2[c] = 0;
}
return 0;
}

int main()
{
int t, cnt = 0;
cin >> t;
while(t--)
{
scanf("%d", &c);
scanf(" %s %s %s", s1, s2, s12);
int ans = solve();
printf("%d %d\n", ++cnt, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: