您的位置:首页 > 编程语言 > C语言/C++

1054. The Dominant Color (20)

2016-10-06 13:11 274 查看


1054. The Dominant Color (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more
than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224).
It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:
24

很水,但是有点抽风,一次过不了就多提交几次。。。。

#include <cstdio>
#include <map>

using namespace std;

int main(){
map<int, int> m;
int r,c,temp, max = 0, index;
scanf("%d%d",&r,&c);
for(int i=0;i<r*c;i++){
scanf("%d",&temp);
m[temp]++;
if(max < m[temp])
max = m[temp],index = temp;
}
printf("%d",index);

return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat c++