您的位置:首页 > 其它

【POJ 3624】 + 01背包 + dp

2016-10-05 16:58 141 查看
Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6

1 4

2 6

3 12

2 7

Sample Output

23

很明显的01背包问题,AC代码 :

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int W[20011],D[20011],dp[20011];
int main()
{
int N,M,i,j;
while(scanf("%d %d",&N,&M)!=EOF)
{
memset(dp,0,sizeof(dp));
for(i = 1 ; i <= N ; i++)
scanf("%d%d",&W[i],&D[i]);
for(i = 1 ; i <= N ; i++)
for(j = M ; j >= W[i] ; j--)
dp[j] = max(dp[j],dp[j - W[i]] + D[i]);
printf("%d\n",dp[M]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj dp