您的位置:首页 > 其它

题目1001:A+B for Matrices

2016-10-05 15:48 344 查看
题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.
输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers
in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.
输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.
样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0

样例输出:
1
5

思路: 用辅助空间在第二个矩阵输入的同时计算对应位置的和,并且计算 i行 和 j列的对应的累加值。最后扫描,得到行列值为0的元素的个数。

code:

#include <bits/stdc++.h>

using namespace std;

int main(){

int a[100][100] ;
int m , n ;
while (cin>>m && m!=0){
cin>>n;
for (int i = 0 ; i < m ; ++i){
a[i]
= 0 ;
for (int j = 0 ; j <n ; ++j){
a[m][j] = 0 ;
cin>>a[i][j];
}
}
int t ;
for (int i = 0 ; i < m ; ++i){
for (int j = 0 ; j <n ; ++j){
cin>>t;
a[i][j]+=t;
a[i]
+=a[i][j] ;
a[m][j]+=a[i][j];
}
}
int sum = 0;
for (int i = 0 ; i < m ;++i)
if (a[i]
== 0 ) sum++;
for (int j = 0 ; j < n ;++j)
if (a[m][j] == 0 ) sum++;
cout<<sum<<endl ;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法