您的位置:首页 > 其它

HDU 5912 Fraction 【模拟】

2016-10-05 12:02 357 查看


Fraction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 138    Accepted Submission(s): 91


Problem Description

Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:



As a talent, can you figure out the answer correctly?

 

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n (n≤8).

The second line contains n integers: a1,a2,⋯an(1≤ai≤10).

The third line contains n integers: b1,b2,⋯,bn(1≤bi≤10).

 

Output

For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.

 

Sample Input

1
2
1 1
2 3

 

Sample Output

Case #1: 1 2

Hint
Here are the details for the first sample:
2/(1+3/1) = 1/2

 

Source

2016中国大学生程序设计竞赛(长春)-重现赛

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const int INF=0x7ffffff;

const int M=100+1;
int a[M],b[M];
int i,j,k,n,m;
int fz,fm;

int gcd(int x,int y)
{
return y?gcd(y,x%y):x;
}

int main()
{
int T;
scanf("%d",&T);
int Case=1;
while(T--){
scanf("%d",&n);
for(i=1;i<=n;i++)scanf("%d",&a[i]);
for(i=1;i<=n;i++)scanf("%d",&b[i]);
int fz=b
,fm=a
;
for(i=n-1;i;i--){
fz+=a[i]*fm;
fm*=b[i];
swap(fz,fm);
}
int t=gcd(fz,fm);
printf("Case #%d: %d %d\n",Case++,fz/t,fm/t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: