您的位置:首页 > 其它

骑士的移动搜索 UVA439

2016-10-05 10:13 197 查看
Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 

 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.". 

 

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

 

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

 

 
题意:给出骑士的骑士位置和目标位置,计算骑士要走多少步
思路:首先要做这道题必须要理解国际象棋中骑士的走法,国际象棋中,骑士是在一个3*2的格子中进行对角线移动,通过画图很容易就知道骑士最多可以朝八个方向移动,那么就朝8个方向进行BFS即可
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
struct point{
char r,c;
point(char r=' ',char c=' '):r(r),c(c){};
};
int vis[60][60],d[60][110];
const int dir[8][2]={{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1},{-1,2},{1,2},{2,1}};
int main()
{
char s[3],t[3];
while(scanf("%s%s",s,t)==2)
{
memset(vis,0,sizeof(vis));
point p;
p.r=s[1];
p.c=s[0];
d[p.r][p.c]=0;
queue<point>q;
q.push(p);
while(!q.empty())
{
point u=q.front();
q.pop();
if(u.r==t[1]&&u.c==t[0])
break;
if(vis[u.r][u.c])
continue;
else
vis[u.r][u.c]=1;
for(int i=0;i<8;i++)
{
char nr=u.r+dir[i][0];
char nc=u.c+dir[i][1];
if(nr>='1'&&nr<='8'&&nc>='a'&&nc<='h')
{
d[nr][nc]=d[u.r][u.c]+1;
q.push(point(nr,nc));
}
}
}
printf("To get from %s to %s takes %d knight moves.\n",s,t,d[t[1]][t[0]]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: