您的位置:首页 > 产品设计 > UI/UE

HDU 5538 House Building(分类暴力)

2016-10-04 17:06 393 查看


House Building

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 1215    Accepted Submission(s): 762


Problem Description

Have you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of  blocks
in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game.



Figure 1: A typical world in Minecraft.

Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build
houses on it. Nyanko-san decided to build on a  big
flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your
job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are  rows
and  columns
on the ground, an intersection of a row and a column is a  square,and
a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array .
Which  indicates
the height of his house on the square of -th
row and -th
column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).

 

Input

The first line contains an integer  indicating
the total number of test cases.

First line of each test case is a line with two integers .

The  lines
that follow describe the array of Nyanko-san's blueprint, the -th
of these lines has  integers ,
separated by a single space.

 

Output

For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.

 

Sample Input

2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

 

Sample Output

30
20



Figure 2: A top view and side view image for sample test case 1.

题意:找给定输入正方体表面积大小,不算地面的;

对于每个位置,考虑它上下左右的高度,只有当前位置比某个方向高时,才加上它们差值的高度;

最后把每个位置的顶层面积算上+1;

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int N=55;
int c

;
int main(){
int t;
scanf("%d",&t);
while(t--){
memset(c,0,sizeof(c));
int n,m;
int ans=0;
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++){
for(int j=1;j<=m;j++){
scanf("%d",&c[i][j]);
}
}
for(int i=1;i<=n;i++){
for(int j=1;j<=m;j++){
if(c[i][j]) ans+=1;
if(c[i][j]>c[i+1][j]){
ans+=(c[i][j]-c[i+1][j]);
}
if(c[i][j]>c[i-1][j]){
ans+=(c[i][j]-c[i-1][j]);
}
if(c[i][j]>c[i][j-1]){
ans+=(c[i][j]-c[i][j-1]);
}
if(c[i][j]>c[i][j+1]){
ans+=(c[i][j]-c[i][j+1]);
}
}
}
printf("%d\n",ans);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: