您的位置:首页 > 其它

HDU 5912 Fraction 【模拟】 (2016中国大学生程序设计竞赛(长春))

2016-10-04 13:27 651 查看



Fraction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2    Accepted Submission(s): 2

Problem Description

Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:



As a talent, can you figure out the answer correctly?

 

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n (n≤8).

The second line contains n integers: a1,a2,⋯an(1≤ai≤10).

The third line contains n integers: b1,b2,⋯,bn(1≤bi≤10).

 

Output

For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.

 

Sample Input

1
2
1 1
2 3

 

Sample Output

Case #1: 1 2

Hint
Here are the details for the first sample:
2/(1+3/1) = 1/2

 

Source

2016中国大学生程序设计竞赛(长春)-重现赛

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  5921 5919 5918 5917 5915 

 

Statistic | Submit | Discuss | Note



题目链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=5912


题目大意:

  给你一个分式,如图,求化简后的分子分母(不含公约数)。

  


题目思路:

  【模拟】

  因为n只有10,可以直接模拟。

//
//by coolxxx
//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<bitset>
#include<memory.h>
#include<time.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
//#include<stdbool.h>
#include<math.h>
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define swap(a,b) ((a)^=(b),(b)^=(a),(a)^=(b))
#define mem(a,b) memset(a,b,sizeof(a))
#define eps (1e-10)
#define J 10
#define mod 1000000007
#define MAX 0x7f7f7f7f
#define PI 3.14159265358979323
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define N 2004
using namespace std;
typedef long long LL;
double anss;
LL aans,sum;
int cas,cass;
int n,m,lll,ans;
int a
,b
;
int gcd(int a,int b)
{
if(!b)return a;
return gcd(b,a%b);
}
int main()
{
#ifndef ONLINE_JUDGEW
//	freopen("1.txt","r",stdin);
//	freopen("2.txt","w",stdout);
#endif
int i,j,k;
//	init();
//	for(scanf("%d",&cass);cass;cass--)
for(scanf("%d",&cas),cass=1;cass<=cas;cass++)
//	while(~scanf("%s",s))
//	while(~scanf("%d",&n))
{
scanf("%d",&n);
for(i=1;i<=n;i++)scanf("%d",&a[i]);
for(i=1;i<=n;i++)scanf("%d",&b[i]);
int fz=b
,fm=a
;
for(i=n-1;i;i--)
{
fz+=a[i]*fm;
fm*=b[i];
swap(fz,fm);
}
i=gcd(fz,fm);
fz/=i,fm/=i;
printf("Case #%d: ",cass);
printf("%d %d\n",fz,fm);
}
return 0;
}
/*
//

//
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐