您的位置:首页 > 其它

HDU 1150 Machine Schedule 最小顶点覆盖

2016-10-04 01:03 393 查看
Machine Schedule
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8299    Accepted Submission(s): 4158

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output
The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3


对(i,x,y)

将A mode x与B mode y连线

构成的图中 所有的顶点就是完成k个任务需要的模式的集合

如果点u与点v之间有连线 则使用了模式u就不需要模式v

显然问题就转化为求最小顶点覆盖

又因为二分图中 最小顶点覆盖=最大匹配

so:

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>
//#define CHECK_TIME

const int K=1001;
const int N=101;
vector<int>G[2*N];
int match[2*N];
bool used[2*N];
inline void add_edge(int a,int b){
G[a].push_back(b);
G[b].push_back(a);
}

bool dfs(int v){
used[v]=true;
for(int i=0;i<G[v].size();++i){
int u=G[v][i],w=match[u];
if(w<0||!used[w]&&dfs(w)){
match[v]=u;
match[u]=v;
return true;
}
}
return false;
}

int bipartite_matching(int V){
int res=0;
fill(match,match+V,-1);
for(int i=0;i<V;++i){
if(match[i]<0){
fill(used,used+V,false);
res+=dfs(i);
}
}
return res;
}
int main()
{
//freopen("/home/lu/文档/r.txt","r",stdin);
//freopen("/home/lu/文档/w.txt","w",stdout);
int k,m,n,a,b,c;
while(~scanf("%d",&n),n){
scanf("%d%d",&m,&k);
for(int i=0;i<m+n;++i)
G[i].clear();
for(int i=0;i<k;++i){
scanf("%d%d%d",&a,&b,&c);
if(b&&c)
add_edge(b,n+c);

131b3
}
int ans=bipartite_matching(n+m);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息