您的位置:首页 > 其它

POJ 2955 Brackets 【区间dp】

2016-10-03 18:55 381 查看
Brackets

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu
Submit Status

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end


Sample Output

6
6
4
0
6


Source

Stanford Local 2004

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const int INF=0x7ffffff;

const int M=100+5;
char s[M];
int dp[M][M];
int i,j,k,n,m,t;

int cheak(char a,char b)
{
if(a=='('&&b==')')
return 1;
if(a=='['&&b==']')
return 1;
return 0;
}

int main()
{
while(~scanf("%s",s),s[0]!='e'){
int len=strlen(s);
for(i=0;i<len;i++){
dp[i][i]=0;
if(cheak(s[i],s[i+1]))
dp[i][i+1]=2;
else dp[i][i+1]=0;
}
for(k=3;k<=len;k++)
for(i=0;i+k-1<len;i++){
dp[i][i+k-1]=0;
if(cheak(s[i],s[i+k-1]))
dp[i][i+k-1]=dp[i+1][i+k-2]+2;
for(j=i;j<i+k-1;j++)
dp[i][i+k-1]=max(dp[i][i+k-1],dp[i][j]+dp[j+1][i+k-1]);
}
printf("%d\n",dp[0][len-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: