您的位置:首页 > 其它

HDU 2588(欧拉函数的应用)

2016-10-03 11:19 288 查看


GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1788    Accepted Submission(s): 895

Problem Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.

(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:

Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

 

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

 

Output

For each test case,output the answer on a single line.

 

Sample Input

3
1 1
10 2
10000 72

 

Sample Output

1
6
260

分析:
若X与n存在大于m的最大公约数,设d=(x,n);则X=q*d,n=p*d; 并且 (p,q)=1;我们可以枚举公约数,由欧拉函数的定义可知 phi(p)即为所求代码如下:
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
using namespace std;

typedef long long int ll;

int euler(int N){
int ans = N;
for(int i=2; i*i<=N; i++){
if(N%i==0)
ans = ans/i*(i-1);
while(N%i==0)
N /= i;
}
if(N>1)
ans = ans/N*(N-1);
return ans;
}

int main(){

int T;
scanf("%d",&T);
int N,M;
int ans;
while(T--){
ans = 0;
scanf("%d %d",&N,&M);
for(int i=1; i*i<=N; i++){
if(i*i==N && i>=M)
ans += euler(i);
else if(N%i==0){
if(i>=M)
ans += euler(N/i);
if(N/i>=M)
ans += euler(i);
}
}
printf("%d\n",ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  欧拉函数 HDU2588