您的位置:首页 > 其它

HDU1241-Oil Deposits

2016-10-02 21:26 253 查看


Oil Deposits

                                                                            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
65536/32768 K (Java/Others)

                                                                                                    Total Submission(s): 25355    Accepted Submission(s): 14592


Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output

0
1
2
2

 

Source

Mid-Central USA 1997

题意:一块矩形区域探测石油,并把这个大区域分成了很多小块。来分析每个小块中是否蕴藏石油。如果这些蕴藏石油的小方格相邻,那么就是同一油藏的一部分。在这块矩形区域,确定有多少不同的油藏。当且仅当他们水平或者垂直或者对角线相邻,两个小方格是相邻的(即8个方向)

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;

#define N 105

int m,n;
int dir[8][2]= {{0,1},{1,1},{1,0},{1,-1},{0,-1},{-1,-1},{-1,0},{-1,1}};
char mp

;
int sum=0;

void dfs(int x,int y)
{
int xx,yy;
for(int i=0; i<8; i++)
{
xx=x+dir[i][0];
yy=y+dir[i][1];
if(mp[xx][yy]=='@'&&xx>=0&&xx<m&&yy>=0&&yy<n)
{
mp[xx][yy]='*';
dfs(xx,yy);
}
}
}

int main()
{
int i,j;
while(cin>>m>>n)
{
if(m==0&&n==0)
break;
for(i=0; i<m; i++)
scanf("%s",mp[i]);
sum=0;
for(i=0; i<m; i++)
{
for(j=0; j<n; j++)
{
if(mp[i][j]=='@')
{
mp[i][j]='*';
dfs(i,j);
sum++;
}
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: