您的位置:首页 > 其它

【LightOJ 1122 + dp】

2016-10-01 18:59 246 查看
Description

Given a set of digits S, and an integer n, you have to find how many n-digit integers are there, which contain digits that belong to S and the difference between any two adjacent digits is not more than two.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case contains two integers, m (1 ≤ m < 10) and n (1 ≤ n ≤ 10). The next line will contain m integers (from 1 to 9) separated by spaces. These integers form the set S as described above. These integers will be distinct and given in ascending order.

Output

For each case, print the case number and the number of valid n-digit integers in a single line.

Sample Input

3

3 2

1 3 6

3 2

1 2 3

3 3

1 4 6

Sample Output

Case 1: 5

Case 2: 9

Case 3: 9

Hint

For the first case the valid integers are

11

13

31

33

66

Problem Setter: Jane Alam Jan

Developed and Maintained by

JANE ALAM JAN

Copyright © 2012

LightOJ, Jane Alam Jan

一道裸 dp 题 : dp[i][j] 表示选好前 i - 1个数 第 i 个数以 j 结尾的所有可能结果;

AC 代码 :

#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int pa[12],dp[12][12];
int main()
{
int T,N,M,i,j,kl,nl = 0;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&M,&N);
for(i = 1 ; i <= M ; i++)
scanf("%d",&pa[i]);
memset(dp,0,sizeof(dp));
for(i = 1 ; i <= M; i++)
dp[1][i] = 1;
for(kl = 2 ; kl <= N ; kl++)
for(i = 1 ; i <= M; i++)
for(j = 1 ; j <= M ; j++)
{
if(abs(pa[j] - pa[i])<= 2)
dp[kl][i] += dp[kl - 1][j];
}
int ans = 0;
for(i = 1 ; i <= M ; i++)
ans += dp
[i];
printf("Case %d: %d\n",++nl,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  lightoj dp