您的位置:首页 > 其它

PAT 1002. A+B for Polynomials (25)

2016-10-01 13:08 405 查看


1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

//浮点型和浮点型的比较肯定不可以通过==和!=比较,整型和浮点型的比较要根据情况而定

//对于判断p[i]为不为零,两个方法均过了

//开始:if(fabs(p[i])>0.0000000001)

//后来:if(p[i]!=0)

#include <stdio.h>
#include <stdlib.h>
int main()
{
double p[1001];//存原始数据
int count=0;//结果有多少项
for(int i=0;i<=1000;i++)//初始化
p[i]=0;
for(int i=1;i<=2;i++){
int k;
int exponent;
double coefficient;
scanf("%d",&k);
for(int j=1;j<=k;j++){
scanf("%d%lf",&exponent,&coefficient);
p[exponent]+=coefficient;
}
}
for(int i=0;i<=1000;i++)
if(fabs(p[i])>0.0000000001)
count++;
printf("%d",count);
for(int t=1000;t>=0;t--){
if(fabs(p[t])>0.0000000001)
printf(" %d %.1f",t,p[t]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: