您的位置:首页 > 大数据 > 人工智能

hdu 4460 Friend Chains【SPFA+暴力】

2016-09-30 14:59 567 查看

Friend Chains

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5266    Accepted Submission(s): 1700


Problem Description

For a group of people, there is an idea that everyone is equals to or less than 6 steps away from any other person in the group, by way of introduction. So that a chain of "a friend of a friend" can be made to connect any 2 persons and it contains no more
than 7 persons.

For example, if XXX is YYY’s friend and YYY is ZZZ’s friend, but XXX is not ZZZ's friend, then there is a friend chain of length 2 between XXX and ZZZ. The length of a friend chain is one less than the number of persons in the chain.

Note that if XXX is YYY’s friend, then YYY is XXX’s friend. Give the group of people and the friend relationship between them. You want to know the minimum value k, which for any two persons in the group, there is a friend chain connecting them and the chain's
length is no more than k .

Input

There are multiple cases. 

For each case, there is an integer N (2<= N <= 1000) which represents the number of people in the group. 

Each of the next N lines contains a string which represents the name of one people. The string consists of alphabet letters and the length of it is no more than 10. 

Then there is a number M (0<= M <= 10000) which represents the number of friend relationships in the group. 

Each of the next M lines contains two names which are separated by a space ,and they are friends. 

Input ends with N = 0.

Output

For each case, print the minimum value k in one line. 

If the value of k is infinite, then print -1 instead.

Sample Input

3

XXX

YYY

ZZZ

2

XXX YYY

YYY ZZZ

0

Sample Output

2

 

题目大意:

翻译过来之后其实就是让你求两点间距离的最大值。

思路:

1、因为点不多,而且后台数据好像并没有卡SPFA,直接求N次单源最短路即可、967ms Ac、

Ac代码:

#include<stdio.h>
#include<string.h>
#include<map>
#include<queue>
#include<iostream>
using namespace std;
struct node
{
int from;
int to;
int w;
int next;
}e[151511];
int head[10000];
int dis[10000];
int vis[10000];
int cont,n,m;
void add(int from,int to,int w)
{
e[cont].to=to;
e[cont].w=w;
e[cont].next=head[from];
head[from]=cont++;
}
int SPFA(int ss)
{
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++)dis[i]=0x3f3f3f3f;
dis[ss]=0;
queue<int >s;
s.push(ss);
while(!s.empty())
{
int u=s.front();
s.pop();
vis[u]=0;
for(int i=head[u];i!=-1;i=e[i].next)
{
int v=e[i].to;
int w=e[i].w;
if(dis[v]>dis[u]+w)
{
dis[v]=dis[u]+w;
if(vis[v]==0)
{
vis[v]=1;
s.push(v);
}
}
}
}
int minn=0;
for(int i=1;i<=n;i++)
{
minn=max(dis[i],minn);
}
if(minn==0x3f3f3f3f)return -1;
else return minn;
}
int main()
{
while(~scanf("%d",&n))
{
if(n==0)break;
char a[1000];
map<string ,int >s;
int contz=0;
for(int i=0;i<n;i++)
{
scanf("%s",a);
if(s[a]==0)
{
s[a]=++contz;
}
}
scanf("%d",&m);
cont=0;
memset(head,-1,sizeof(head));
for(int i=0;i<m;i++)
{
scanf("%s",a);
int u=s[a];
scanf("%s",a);
int v=s[a];
add(u,v,1);
add(v,u,1);
}
int ans=0;
int flag=0;
for(int i=1;i<=n;i++)
{
int tmp=SPFA(i);
if(tmp==-1)
{
flag=1;break;
}
else ans=max(ans,tmp);
}
if(flag==1)printf("-1\n");
else printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 4460 杭电 4460