您的位置:首页 > 编程语言 > C语言/C++

1096. Consecutive Factors

2016-09-29 19:00 295 查看


1096. Consecutive Factors (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number
of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing
order, and 1 is NOT included.
Sample Input:
630

Sample Output:
3
5*6*7

容易超时,从2到sqrt(num),找对应值作为累乘起点时连续因子的个数的最大值和对应的因子值,输出。
#include <iostream>
#include <cmath>

using namespace std;

int main()
{
int num;
cin>>num;
int maxn=sqrt((double)num);
int maxcnt=0;
int maxstart=1;
for(int i=2;i<=maxn;++i)
{
int tmp=num;
int start=i;
int cnt=0;
while(tmp%start==0)
{
cnt++;
tmp/=start;
start++;
}
if(cnt>maxcnt)
{
maxcnt=cnt;
maxstart=start;
}
}
maxstart=maxstart-maxcnt;
if(maxcnt==0)
{
maxcnt=1;
maxstart=num;
}
cout<<maxcnt<<endl;
cout<<maxstart;
while(--maxcnt)
cout<<"*"<<++maxstart;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT C++