您的位置:首页 > 大数据 > 人工智能

HDU 1787 GCD Again

2016-09-29 17:40 302 查看
Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest? 

No? Oh, you must do this when you want to become a "Big Cattle". 

Now you will find that this problem is so familiar: 

The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little
more difficult problem: 

Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1. 

This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study. 

Good Luck! 

Input

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed. 

Output

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input. 

Sample Input

2
4
0


Sample Output

0
1

根号板子题
#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
#define loop(i,j,k) for (int i = j;i != -1; i = k[i])
#define lson x << 1, l, mid
#define rson x << 1 | 1, mid + 1, r
#define ff first
#define ss second
#define mp(i,j) make_pair(i,j)
#define pb push_back
#define pii pair<int,LL>
#define inone(x) scanf("%d", &x);
#define intwo(x,y) scanf("%d%d", &x, &y);
using namespace std;
typedef unsigned long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-4;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e5 + 10;
int n;

int phi(int x)
{
int res = 1;
for (int i = 2; i*i <= x; i++)
{
if (x % i) continue;
res *= i - 1; x /= i;
while (x%i == 0) res *= i, x /= i;
}
return res * max(x - 1, 1);
}

int main()
{
while (scanf("%d", &n), n)
{
printf("%d\n", n - phi(n) - 1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU