您的位置:首页 > 其它

poj 3280 Cheapest Palindrome(区间DP->字符串的增删价值最优)@

2016-09-29 08:35 405 查看
Cheapest Palindrome
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit Status

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of
inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated
costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 

Line 2: This line contains exactly M characters which constitute the initial ID string 

Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800


Sample Output

900


Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost
would be 350 + 200 + 350 = 900, which is the minimum.

如果要形成回文串,新加的字符一定要和边界两端的字符对应,所以特判两端就可以了,不用从中间枚举

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <set>
#include <queue>
using namespace std;
const int N = 1e5+10;
char str
, s[10];
int c
, dp[2010][2010];

int main()
{
int n, m;
while(scanf("%d %d",&n, &m)!=EOF)
{
scanf("%s",str);
int len=m;
for(int i=0;i<n;i++)
{
scanf("%s",s);
int x=s[0]-'a', y, z;
scanf("%d %d",&y, &z);
c[x]=min(y,z);
}
for(int i=0;i<=len;i++) dp[i][i]=0;
for(int i=1;i<len;i++)
{
for(int j=0;j+i<len;j++)
{
int k=j+i,x=str[j]-'a',y=str[k]-'a';
dp[j][k]=min(dp[j+1][k]+c[x],dp[j][k-1]+c[y]);
if(str[j]==str[k]) dp[j][k]=min(dp[j][k],dp[j+1][k-1]);
}
}
printf("%d\n",dp[0][len-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: