您的位置:首页 > 其它

POJ:1703 Find them, Catch them(种类并查集(影子并查集))

2016-09-28 23:15 603 查看
Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42116 Accepted: 12951
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source
POJ Monthly--2004.07.18
题目大意:t组数据,一个n,一个q,代表n个人,q组操作。A a b代表查询a b是否在同一集团里,D a b代表是a b不是同一个集团。
解题思路:影子并查集,D a b代表a b不是一个集合,那么把a和b+n放到一个集合,b和a+n放在一个集合,就分开了a和b。(新学习的知识,我是这么理解的,嘿嘿)
代码如下:
#include <cstdio>
#define MAXM 100010
int pre[MAXM*2];
int find(int x)
{
int r=x;
while(r!=pre[r])
{
r=pre[r];
}
int k=x,t;
while(k!=r)//记得压缩路径,否则超时
{
t=pre[k];
pre[k]=r;
k=t;
}
return r;
}
void hebing(int a,int b)
{
int fx=find(a);
int fy=find(b);
if(fx!=fy)
{
pre[fx]=fy;
}
}
int main()
{
int t,n,m;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n*2;i++)
{
pre[i]=i;
}
for(int i=0;i<m;i++)
{
char op[3];
int a,b;
scanf("%s%d%d",op,&a,&b);
if(op[0]=='A')
{
if(find(a)==find(b))
{
printf("In the same gang.\n");
}
else
{
if(find(a)==find(b+n)||find(a+n)==find(b))//b的镜像与a在一个集合等价于a的镜像与b在同一个集合
{
printf("In different gangs.\n");
}
else
{
printf("Not sure yet.\n");
}
}
}
else
{
hebing(a,b+n);//将b的镜像与a合并到一个集合
hebing(a+n,b);//将a的镜像与b合并到一个集合
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  并查集 思维 技巧