您的位置:首页 > 其它

POJ 1328 Radar Installation

2016-09-28 20:03 316 查看

Radar Installation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 77830 Accepted: 17412
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d
distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is
followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

解析:题目其实很简单,就是简单的贪心+sort;以给的点为圆心做圆,圆与x轴交于两点,一点是s.start,另一点是s.end,如果与x轴不相交,则输出-1;
然后就会得到s的数组s[1-n];然后以s.endsort一遍,就得到了有顺序的一组数;现在就是简单的贪心了;
#include <bits/stdc++.h>
const double INF=0x3f3f3f3f;
using namespace std;

struct node
{
double start, end;
};
node s[1500];

double cmp(node a, node b)//以s.end升序写的cmp;
{
return a.end<b.end;
}
int main()
{
int n, d, i;
double x, y;
int K=0;
while(cin>>n>>d)
{
if(n==0||d==0)
return 0;
int flag=1;
for(i=0; i<n; i++)
{
cin>>x>>y;
if(y<=d)
{
s[i].start=x-sqrt(d*d-y*y);
s[i].end=x+sqrt(d*d-y*y);
}
else
flag=0;
}
cout<<"Case "<<++K<<": ";
if(flag==0)
{
cout<<"-1"<<endl;
}
else
{
sort(s,s+n,cmp);//快排:s.end升序
//          for(i=0;i<n;i++)
//          printf("%.2lf  %.2lf\n",s[i].start, s[i].end);
int sum=0;
double temp = -INF;
for(i=0; i<n; i++)
{
if(temp<s[i].start)
{
sum++;
temp=s[i].end;
}
}
cout<<sum<<endl;
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: