您的位置:首页 > 其它

hdu 1358 floyd+输出字典需最小最短路径

2016-09-28 17:50 399 查看
Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 

The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 

a21 a22 ... a2N 

............... 

aN1 aN2 ... aNN 

b1 b2 ... bN 

c d 

e f 

... 

g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and
g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 

Path: c-->c1-->......-->ck-->d 

Total cost : ...... 

...... 

From e to f : 

Path: e-->e1-->..........-->ek-->f 

Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0


Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17


修改Floyd模板,加一个pre数组存储后继结点

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<set>
#include<algorithm>
#include<sstream>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
const int MAXN=110;
int dist[MAXN][MAXN];
int tax[MAXN];
int pre[MAXN][MAXN];//pre[i][j]存储i到j字典序最小最短路径中i的后继
int main()
{
int n;
while(cin>>n)
{
if(n==0)
return 0;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
scanf("%d",&dist[i][j]);
if(dist[i][j]==-1)
dist[i][j]=inf;
pre[i][j]=j;
}
for(int i=1;i<=n;i++)
scanf("%d",&tax[i]);
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
if(dist[i][j]>dist[i][k]+dist[k][j]+tax[k])
{
dist[i][j]=dist[i][k]+dist[k][j]+tax[k];
pre[i][j]=pre[i][k];
}
else if(dist[i][j]==dist[i][k]+dist[k][j]+tax[k])
{
pre[i][j]=min(pre[i][j],pre[i][k]);
}
}
int u,v;
while(cin>>u>>v)
{
if(u==-1||v==-1) break;
cout<<"From "<<u<<" to "<<v<<" :"<<endl;
cout<<"Path: ";
int k=u;
cout<<u;
while(k!=v)
{
cout<<"-->"<<pre[k][v];
k=pre[k][v];
}
cout<<endl;
cout<<"Total cost : "<<dist[u][v]<<endl<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: