您的位置:首页 > 其它

PAT(A) - 1056. Mice and Rice (25)

2016-09-28 16:50 351 查看
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in
this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively.
If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1)
where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from
0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:
5 5 5 2 5 5 5 3 1 3 5


思路分析:一个模拟题,稍微复杂一点。待我稍后补充思路,AC代码如下:

#include <cstdio>
#include <vector>
#include <string.h>

#define MAX 100000

int isExit[MAX] = { 0 };
int weight[MAX] = { 0 };
int q[MAX] = { 0 };

using namespace std;

int main() {
//freopen( "123.txt", "r", stdin );
for( int i = 0; i < MAX; i++ ) isExit[i] = 1;

int n, m;
scanf( "%d%d", &n, &m );

for( int i = 0; i < n; i++ ) {
scanf( "%d", &weight[i] );
}

for( int i = 0; i < n; i++ ) {
scanf( "%d", &q[i] );
}

// 每轮生存的人数,刚开始为n
int live = n;
// curRank为每轮淘汰玩家的排名
int curRank;
// 当生存的人数只有一个时,游戏结束
while( live > 1 ) {
if( live % m == 0 ) {
live = live / m;
}
else {
live = live / m + 1;
}
// 计算出淘汰玩家的名次
curRank = live + 1;
int count = 0;
int maxWeight = -1;
vector<int> vec;
// 开始进行游戏,计算每轮淘汰的玩家
for( int i = 0; i < n; i++ ) {
int index = q[i];
if( isExit[index] == 1 ) {
count++;
if( weight[index] > maxWeight ) {
maxWeight = weight[index];
}
vec.push_back( index );
//printf( "%d加入小组\n", index );
}
if( count == m || i == n - 1 ) {
for( int j = 0; j < vec.size(); j++ ) {
int lowser = vec[j];
if( weight[lowser] < maxWeight ) {
isExit[lowser] = curRank;
//printf( "%d 淘汰了 排名:%d \n", lowser, curRank );
}
}
count = 0;
vec.clear();
maxWeight = -1;
//printf( "\n" );
}
}
}

for( int i = 0; i < n; i++ ) {
if( i == 0 )
printf( "%d", isExit[i] );
else
printf( " %d", isExit[i] );
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: