您的位置:首页 > 其它

POJ 2777 Count Color

2016-09-28 11:10 309 查看
Count Color

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 43571 Accepted: 13189

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, … L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

“C A B C” Color the board from segment A to segment B with color C.

“P A B” Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, … color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains “C A B C” or “P A B” (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4

C 1 1 2

P 1 2

C 2 2 2

P 1 2

Sample Output

2

1

Source

POJ Monthly–2006.03.26,dodo

线段树更新区间,要利用懒标记,否则跟新到叶子会超时。

用由于颜色数很少所以可以用2<<30来压缩下状态,使每次修改状态时做到O(1);

之后便是注意懒标记下放的一些细节就好。

//最后统计1的个数时我写的略挫。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
#define MAXN 400005
#define ll long long
struct p{ll l,r,kind,num;}tree[MAXN];
void creatree(ll i,ll l,ll r)
{
tree[i].l=l;tree[i].r=r; tree[i].num=1;tree[i].kind=-1;
if (l==r) return;
ll mid=(l+r)>>1;
creatree(i<<1,l,mid);
creatree((i<<1)+1,mid+1,r);
}
void updata(ll i,ll l,ll r,ll c)
{
if (tree[i].l==l&&tree[i].r==r)
{
tree[i].num=(1<<(c-1));
tree[i].kind=-1;
return;
}
if (tree[i].kind==-1) //懒标记下放,tree[i].kind==-1代表这段区间只有一种颜色
{
tree[i<<1].num=tree[i].num;
tree[(i<<1)+1].num=tree[i].num;
if ((1<<(c-1))!=tree[i].num) tree[i].kind=0;//由于插入颜色与区间颜色不同所以区间的颜色大于一种
tree[i<<1].kind=-1;tree[(i<<1)+1].kind=-1;//由于当前区间颜色一样,所以其子区间颜色必然相同
}
ll mid=(tree[i].l+tree[i].r)>>1;
if (r<=mid) updata(i<<1,l,r,c);
if (l>mid) updata((i<<1)+1,l,r,c);
if (l<=mid&&r>mid) {updata(i<<1,l,mid,c);updata((i<<1)+1,mid+1,r,c);}
tree[i].num=(tree[i<<1].num)|(tree[(i<<1)+1].num);
}
ll _find(ll i,ll l,ll r)
{
if (tree[i].l==l&&tree[i].r==r)
{
return tree[i].num;
}
if (tree[i].kind==-1)//同上懒标记下放
{
tree[i<<1].num=tree[i].num;
tree[(i<<1)+1].num=tree[i].num;
tree[i<<1].kind=-1;tree[(i<<1)+1].kind=-1;
}
ll mid=(tree[i].l+tree[i].r)>>1;
if (r<=mid) return _find(i<<1,l,r);
if (l>mid) return _find((i<<1)+1,l,r);
if (l<=mid&&r>mid) return (_find(i<<1,l,mid))|(_find((i<<1)+1,mid+1,r));
}
int main()
{
ll l,t,o;
scanf("%I64d%I64d%I64d",&l,&t,&o);
creatree(1,1,l);
while (o--)
{
char str[10];
ll a,b,c;
scanf("%s",str);
if (str[0]=='C')
{
scanf("%I64d%I64d%I64d",&a,&b,&c);
updata(1,min(a,b),max(a,b),c);
}
else
{
scanf("%I64d%I64d",&a,&b);
ll t=_find(1,min(a,b),max(a,b));
ll cnt=0;
while (t)
{
if (t%2) cnt++;
t/=2;
}
printf("%d\n",cnt);
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: