您的位置:首页 > 其它

【codevs 1078】最小生成树

2016-09-27 23:55 309 查看
1078 最小生成树

时间限制: 1 s

空间限制: 128000 KB

题目等级 : 白银 Silver

题解

题目描述 Description

农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。 约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了使花费最少,他想铺设最短的光纤去连接所有的农场。 你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。 每两个农场间的距离不会超过100000

输入描述 Input Description

第一行: 农场的个数,N(3<=N<=100)。

第二行..结尾: 接下来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们每行限制在80个字符以内,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为线路从第i个农场到它本身的距离在本题中没有意义。

输出描述 Output Description

只有一个输出,是连接到每个农场的光纤的最小长度和。

样例输入 Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

样例输出 Sample Output

28

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 100005;
int tot = 1,xc,ans = 0;
int n,num[MAXN];
int cnt = 1;

struct edge
{
int f,t,v;
}l[MAXN];

bool cmp(edge a,edge b)
{
return a.v < b.v;
}

int main()
{
scanf("%d",&n);
for(int i = 1; i <= n; i ++)
{
for(int j = 1; j <= n; j ++)
{
l[cnt].f = i;
l[cnt].t = j;
scanf("%d",&l[cnt].v);
cnt ++;
}
}
int c = n * n;
sort(l + 1,l + c + 1, cmp);
for(int i = n + 1; i < cnt; i ++)
{
if(!num[l[i].f])
{
if(!num[l[i].t])
{
num[l[i].f] = tot;
num[l[i].t] = tot;
tot ++;
ans += l[i].v;
}
else
num[l[i].f] = num[l[i].t],ans += l[i].v;
}
else
{
if(num[l[i].t])
{
if(num[l[i].f] != num[l[i].t])
{
xc = num[l[i].t];
for(int j = 1; j <= n; j ++)
if(num[j] == xc)
num[j] = num[l[i].f];
ans += l[i].v;
}
}
else
num[l[i].t] = num[l[i].f],ans += l[i].v;
}
}
printf("%d\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: