您的位置:首页 > 其它

UVA 548 Tree(二叉树建树)

2016-09-27 21:09 435 查看
Question:

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a

path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values

of nodes along that path.

Input

The input file will contain a description of the binary tree given as the inorder and postorder traversal

sequences of that tree. Your program will read two line (until end of file) from the input file. The first

line will contain the sequence of values associated with an inorder traversal of the tree and the second

line will contain the sequence of values associated with a postorder traversal of the tree. All values

will be different, greater than zero and less than 10000. You may assume that no binary tree will have

more than 10000 nodes or less than 1 node.

Output

For each tree description you should output the value of the leaf node of a path of least value. In the

case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input

3 2 1 4 5 7 6

3 1 2 5 6 7 4

7 8 11 3 5 16 12 18

8 3 11 7 16 18 12 5

255

255

Sample Output

1

3

255

题目大意:给你一棵二叉树的中序遍历和后序遍历,找到一个叶子节点使这条路权值和最小,如果有多解,则输出节点最小的叶节点

解题思路:根据中序遍历和后序遍历建树,然后dfs找到权值和最小的叶节点

(http://vjudge.net/contest/132880#problem/C)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <sstream>  //为读取输入
using namespace std;
const int maxn=1e4+5;
const int INF=0x3f3f3f3f;
int l[maxn],r[maxn],a[maxn],b[maxn];
int n,best_sum,best;
int build(int L1,int R1,int L2,int R2)
{
if(L1>R1)
return 0;
int root=b[R2];
int p=L1;
while(a[p]!=root)
p++;
int cnt=p-L1;
l[root]=build(L1,p-1,L2,L2+cnt-1);
r[root]=build(p+1,R1,L2+cnt,R2-1);
return root;
}  //运用递归建树
void dfs(int u,int sum)
{
sum+=u;
if(!l[u]&&!r[u])
{
if(sum<best_sum||(sum==best_sum&&u<best))
{
best=u;
best_sum=sum;
}
}
if(l[u])   dfs(l[u],sum);
if(r[u])   dfs(r[u],sum);
}
bool read(int *w)  //输入读取(这十分重要)
{
string line;
if(!getline(cin,line))
return false;
stringstream ss(line);
n=0;
int x;
while(ss>>x)
w[n++]=x;
return n>0;
}
int main()
{
while (read(a))  //读取后分别保存在数组a和数组b中
{
read(b);
best_sum=INF;
build(0,n-1,0,n-1);
dfs(b[n-1],0);
printf("%d\n",best);
}
return 0;
}


体会:基本建树一定要掌握,这是一个二叉树建树的基本题型
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二叉树 算法 ACM