您的位置:首页 > 其它

poj 1511 Invitation Cards (最短路)

2016-09-27 09:44 197 查看
Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information
and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special
course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait
until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting
and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program
that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number
of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which
is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output
46
210

Source

Central Europe 1998
题意:给出n个点和n条有向边,求所有点到源点1的来回最短路之和(保证每个点都可以往返源点1)

思路:这个数据范围太大,明显的不能用floyd,dijstra,bellman-ford这些算法,用spfa的话也不能用邻接矩阵存,因为点太多了,所以采用spfa的邻接表存储搞定
稍微有点注意的地方是,来回之和只需要将所有的边反向再从1到所有点求最短路就是他们的最短回路;

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int N=1000005;
typedef long long LL;
const LL maxn=0xffffffff;
struct node{
int w,now,next;
}str[2]
;
LL head[2]
,vis
;
LL d
,sum;
LL n,m;
void spfa(int x)
{
for(int i=1;i<=n;i++)
d[i]=maxn;
d[1]=0;
queue<int>q;
q.push(1);
vis[1]=1;
while(q.size())
{
int zx=q.front();
q.pop();
vis[zx]=0;
for(int i=head[x][zx];i!=-1;i=str[x][i].next)
{
int zy=str[x][i].now;
if(d[zy]>d[zx]+str[x][i].w)
{
d[zy]=d[zx]+str[x][i].w;
if(!vis[zy])
q.push(zy);
}
}
}
for(int i=2;i<=n;i++)
sum+=d[i];
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
sum=0;
memset(str,-1,sizeof(str));
memset(head,-1,sizeof(head));
scanf("%I64d%I64d",&n,&m);
for(int i=1;i<=m;i++)
{
int a,b,w;
scanf("%d%d%d",&a,&b,&w);
str[0][i].w=w;
str[0][i].now=b;
str[0][i].next=head[0][a];
head[0][a]=i;
str[1][i].w=w;
str[1][i].now=a;
str[1][i].next=head[1][b];
head[1][b]=i;
}
memset(vis,0,sizeof(vis));
memset(d,0,sizeof(d));
spfa(0);
memset(vis,0,sizeof(vis));
memset(d,0,sizeof(d));
spfa(1);
printf("%I64d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: