您的位置:首页 > 其它

HDU5229-ZCC loves strings

2016-09-26 22:09 357 查看


ZCC loves strings

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
262144/131072 K (Java/Others)

                                                                                                          Total Submission(s): 939    Accepted Submission(s): 362


Problem Description

ZCC has got N strings. He is now playing a game with Miss G.. ZCC will pick up two strings among those N strings randomly(A string can't be chosen twice). Each string has the same probability to be chosen. Then ZCC and Miss G. play in turns. Miss G. always
plays first. In each turn, the player can choose operation A or B.

  

Operation A: choose a non-empty string between two strings, and delete a single letter at the end of the string.

    

Operation B: When two strings are the same and not empty, empty both two strings.

  

The player who can't choose a valid operation loses the game.

  

ZCC wants to know what the probability of losing the game(i.e. Miss G. wins the game) is.

 

Input

The first line contains an integer T(T≤5) which
denotes the number of test cases.

  

For each test case, there is an integer N(2≤N≤20000) in
the first line. In the next N lines, there is a single string which only contains lowercase letters. It's guaranteed that the total length of strings will not exceed 200000.

 

Output

For each test case, output an irreducible fraction "p/q" which is the answer. If the answer equals to 1, output "1/1" while output "0/1" when the answer is 0.

 

Sample Input

1
3
xllendone
xllendthree
xllendfour

 

Sample Output

2/3

 

Source

BestCoder Round #41

 

Recommend

hujie

题意:有N个字符串,从这N个串中等概率随机选两个字符串(不可以是同一个)。然后两个人轮流操作,有两种操作:如果两个字符串相同,可以删除这两个字符串;不相同则选择一个字符串,删掉最后一个字符。第一个不能操作的人输。问先手获胜的概率

解题思路:对于先手来说,如果两个串相同,则先手赢。如果两个串的总共有奇数个字符则先手赢,否则先手输。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>

using namespace std;

string s[20009];

int gcd(int x,int y)
{
if(x>y) return gcd(y,x);
while(y%x)
{
int t=x;
x=y%x;
y=t;
}
return x;
}

int main()
{
int t,n,a,b;
scanf("%d",&t);
while(t--)
{
a=b=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
cin>>s[i];
if(s[i].length()%2) a++;
else b++;
}
sort(s,s+n);
int sum=n*(n-1)/2;
int sum1=a*b;
int k=1;
for(int i=1;i<n;i++)
{
if(s[i]==s[i-1]) k++;
else
{
sum1+=(k-1)*k/2;
k=1;
}
}
sum1+=(k-1)*k/2;
printf("%d/%d\n",sum1/gcd(sum1,sum),sum/gcd(sum,sum1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: