您的位置:首页 > 其它

poj-1703-Find them, Catch them【并查集】

2016-09-26 21:00 302 查看
题目链接:点击打开链接

Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42061 Accepted: 12934
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.


题解:并查集应用。这个题目和【食物链】类似。same[
i ] = 0  表示 i 与父节点同 gang,same[ i ] = 1 表示与父节点不同 gang。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m;
int fa[100010];
bool same[100010];
void init()
{
for(int i=1;i<=n;i++)
{
fa[i]=i;
same[i]=0;
}
}
int find(int x)
{
if(x==fa[x]) return x;
int t=find(fa[x]); // 这个递归压缩必须拆开来写,这个点一直 WA
same[x]=(same[fa[x]]+same[x])&1;
return fa[x]=t;
}
void Union(int x,int y)
{
int nx=find(x);
int ny=find(y);
fa[nx]=ny;
if(same[y]==0)
same[nx]=1-same[x];
else
same[nx]=same[x];
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
init();
while(m--)
{
char ch;
int a,b;
getchar();
scanf("%c%d%d",&ch,&a,&b); // 以下的两种输入方式都可以
// scanf("%*c%c%d%d",&ch,&a,&b);
// scanf(" %c %d %d",&ch,&a,&b);
if(ch=='D')
Union(a,b);
else
{
int fx=find(a);
int fy=find(b);
if(fx!=fy)
puts("Not sure yet.");
else if(same[a]==same[b])
puts("In the same gang.");
else
puts("In different gangs.");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: