您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2016-09-26 20:05 274 查看


数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


Input

第一行输入元素个数n;

第二行输入n个整数。


Output

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。


Example Input

10
21 30 14 55 32 63 11 30 55 30



Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21



#include <iostream>
#include <stdlib.h>
using namespace std;
typedef struct node
{
int data;
struct node *next;
}sq;
sq *sca(int n)
{
sq *head,*p;
head=(sq *)malloc(sizeof(sq));
head->next=NULL;
for(int i=0;i<n;i++)
{
p=(sq *)malloc(sizeof(sq));
cin>>p->data;
p->next=head->next;
head->next=p;
}
return head;
}
void pri(sq *head)
{
sq *p;
p=head->next;
while(p)
{
cout<<p->data;
p=p->next;
if(p)
cout<<" ";
else
cout<<endl;
}
}
void delrep(sq *head,int n)
{
sq *p,*be,*tail;
tail=head->next;
while(tail->next)
{
be=tail;
p=be->next;
while(p)
{
if(p->data==tail->data)
{
be->next=p->next;
free(p);
p=be->next;
n--;
}
else
{
be=p;
p=p->next;
}
}
tail=tail->next;
}
cout<<n<<endl;
pri(head);
}
int main()
{
int n,d;
sq *head;
cin>>n;
head=sca(n);
cout<<n<<endl;
pri(head);
delrep(head,n);
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: