您的位置:首页 > 编程语言 > C语言/C++

C++ 面向对象程序设计上机练习四(变量引用)

2016-09-26 17:16 302 查看
题目链接:点击打开链接

面向对象程序设计上机练习四(变量引用)

Time Limit: 1000MS
Memory Limit: 65536KB
Submit

Statistic

Problem Description

将变量的引用作为函数形参,实现2个int型数据交换。

Input

输入2个int型整数。

Output

输出2个整数交换前后的值。

Example Input

88 66


Example Output

88 66
66 88


Hint

Author

zlh

代码实现:

#include <iostream>
using namespace std;

template <typename T>

T Swap(T &a,T &b){
T c = a;
a = b;
b = c;
}

int main()
{
int a,b;
cin>>a>>b;
cout<<a<<" "<<b<<endl;
Swap(a,b);
cout<<a<<" "<<b<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: