您的位置:首页 > 其它

hdu 1712 ACboy needs your help (分组背包)

2016-09-25 16:00 375 查看
分组
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the
profit? 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 

Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 

N = 0 and M = 0 ends the input. 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0


Sample Output

3
4
6


分组背包,01背包的进化体。。。。组内有排斥,组间可相容。。。

分组背包问题,详见背包九讲。

分析:将天数m作为背包的容量,科目数目作为背包的种类数目,天数j作为背包的重量,因为一个科目只能选一次,对应于

每组中的物品只能选一件,正好是分组背包问题。

方程:dp[j]=max(dp[j-k]+a[i][k],dp[j])

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 1000;
const int inf = 999999999;
int dp
, a

;

int main()
{
int n, m;
while(scanf("%d %d", &n, &m),n||m)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
scanf("%d",&a[i][j]);
}
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=m;j>=1;j--)
{
for(int k=1;k<=j;k++)
{
dp[j]=max(dp[j-k]+a[i][k],dp[j]);
}
}
}
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: