您的位置:首页 > 其它

poj 1703 Find them, Catch them (并查集,思维)

2016-09-24 19:03 288 查看
Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42026 Accepted: 12919
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

首先想到会用到并查集,把属于同一组的合并与一个集合。

技巧之处在于给出两个数,是对立的,一定不属于一个集合,op[x]代表和x处于对立的另一个集合;

然后分x y出现的情况讨论。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int per[100000+10],op[100000+10];
int find(int x)
{
if(x==per[x])
return x;
else
return per[x]=find(per[x]);
}
void merge (int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
per[fy]=fx;
}
int main()
{
int t,n,m,x,y;
char c;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
per[i]=i;
op[i]=0;
}
for(int i=0;i<m;i++)
{
getchar();
scanf("%c %d %d",&c,&x,&y);
if(c=='D')
{
if(op[x]==0&&op[y]==0)//x y 都没出现
{
op[x]=y;
op[y]=x;
}
else if(op[y]==0)   //x出现,y没出现过
{
op[y]=x;
merge(y,op[x]);
}
else if(op[x]==0)   //x没出现过,y出现过
{
op[x]=y;
merge(x,op[y]);
}
else    //都出现过
{
merge(x,op[y]);
merge(y,op[x]);
}
}
else
{
if(find(x)==find(y))    //x,y同一集合
printf("In the same gang.\n");
else if(find(x)==find(op[y]))//x和op[y]同一集合
printf("In different gangs.\n");
else//无法判断
printf("Not sure yet.\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: