您的位置:首页 > 其它

HDU 3555 Bomb (数位dp)

2016-09-22 23:51 330 查看

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 15699    Accepted Submission(s): 5715


[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes
the sub-sequence "49", the power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.
[align=left]Sample Input[/align]

3
1
50
500

[align=left]Sample Output[/align]

0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

[align=left]Author[/align]
fatboy_cw@WHU
[align=left]Source[/align]
2010 ACM-ICPC
Multi-University Training Contest(12)——Host by WHU
[align=left]Recommend[/align]
zhouzeyong   |   We have carefully selected several similar problems for you:  3554 3556 3557 3558 3559 

题解:把HDU 2089 改改就行了.......我还因为一个if判断条件吃了几发TLE....

AC代码:
//#include<bits/stdc++.h>
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<string.h>
using namespace std;
typedef long long ll;
int dig[63];
ll dp[63][2][63];

ll dfs(int pos,bool have,int last,int flag)
{
int i;
if (pos < 0) return have;
if (flag==0 && dp[pos][have][last]!=-1) return dp[pos][have][last];

int n=flag ? dig[pos] : 9;
ll ans=0;
for(i=0;i<=n;i++)
{
if (last==4 && i==9) ans += dfs(pos-1,true,i,flag && (i==n));
else ans+=dfs(pos-1,have,i,flag && (i==n));
}
if (flag==0)
{
dp[pos][have][last]=ans;
}
return ans;
}
ll solve(ll x)
{
int len = 0;
while(x)
{
dig[len++] = x % 10;
x /= 10;
}
return dfs(len-1,0,0,1);
}

int main()
{
ll x;
int t;
scanf("%d",&t);
while(t--)
{
memset(dp,-1,sizeof(dp));
scanf("%I64d",&x);
printf("%I64d\n",solve(x));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: